• I have many teachers getting a message each time they open the ViewBoard app, "A newer version of this application is available." So when they touch update, it reads, "File extension does not match." They are still able to use the ViewBoard, but I am wondering how to fix this issue so I will stop getting asked daily.


  • Hi Hayden:

    Thank you for reporting the issue. That is a known issue which has been fixed in the newest version Whiteboard for Android. The issue happens when user wants to update Whiteboard for Android. However, there is a way to bypass the issue when updating Whiteboard for Android.

    Please select 'Package Installer' when updating Whiteboard for Android.


  • @frank-chu-viewsonic-com Is there a way to go back and select package installer. I have a few teachers who pressed the other option so any time they try to update, it just says file extension does not match.


  • Hi Hayden:

    Please do the following steps to reset the setting.

    1. Go to 'App Info' menu of Whiteboard for Android.
    2. Tap 'Open by default' section.
    3. Tap 'CLEAR DEFAULT' button.

  • @frank-chu-viewsonic-com We are having the same issue. I have a Viewsonic touchscreen. This may be a dumb questions, but how do I get to the menu of Whiteboard for Android? When I log in to myviewboard.com account, I do not see a Whiteboard for Android option. Thanks for any help.


  • Hi @jsquier:

    You just do the following actions to go to the 'App Info' menu of Whiteboard for Android:

    1. Long press 'Whiteboard' app icon in the app list on ViewBoard.
    2. Drag the icon to the top 'App Info' text label.
    3. The 'App Info' menu will show up.

  • @frank-chu-viewsonic-com

    Hello Frank we are having the same issue in our district. When updating the boards teachers are choosing to update with ‘whiteboard’ and not the ‘package installer’, And they’re also choosing ‘always’ so it doesn’t allow them to go back to choose the package installer. I am following that directions per this reply but I cannot find the app information list to even drag the whiteboard to and I am on the panel now. Please support so that I can support our teachers. Thank you!

    The model number is IFP7550-2


  • Hey @armahan ~

    Please extend out the application's list and hold onto Whiteboard (not shortcut icon and as seen in screenshot below), drag to the top where it says "App Info" and release it here. Scroll downwards and click on "Open by default", choose "CLEAR DEFAULTS" and it will resolve the issue.

    screenshot.jpg