Screens all showing as offline when trying to manage


  • Hi All,

    I'm having a problem where our screens are not connecting to the management app or site so I cannot manage them.

    When I open the management app on the screen it simply sits there and never gives a pin code. When I add the screen manually into the web management page the screens never show online.

    I think this is down to a firewall or filtering system block however our service provider has allowed all of the required ports and URL's we can find in the guides etc.

    Has anyone had this issue and did you find a fix?

    Thanks

    Noel


  • Hi Noel,
    It sounds like this is firewall block issue,
    could you please check with your service provider again they whitelist following myviewboard domain, thanks.

    Peja

    TCP 8883 and 443,
    Whitelist Domains
    • *myviewboard.com
    This is required for the web applications ecosystem to function
    • *myviewboard.cloud
    This is required for proper functioning of web service resources
    myviewboardclips.com
    This allows proper functioning of myViewBoard Clips
    • *firebraseio.com
    Used by video and audio streaming features
    • *amazonaws.com
    Used by AWS services
    Please be sure to include * asterisks where shown above.


  • This post is deleted!

  • This post is deleted!

  • We finally got our screens all showing online however over the weekend they have gone offline again. Our service provider who manages our Firewall and Filtering states they haven't changed anything so the problem isn't on their end.

    Has anyone had it where screens just all appear offline suddenly? All 12 screens lost connection to myViewBoard Manager within a 48 hour period.


  • @noelmm
    Hi Noel, could you please try to open the manager app on the screen and let us know what message showed in the manager app?
    And please let us know your entity name, we will check what happened, thank you.


  • @peja-cw-chang Hi,

    The manager app on the screen works as expected and states it's paired. Our service provider thinks the IP address has changed that was being used last week (they have been advised multiple times to whitelist AWS and not an IP address but re reluctant).

    Our Entity name is The Burton Borough School


  • @noelmm Hi,
    All devices shows offline in Manager web means we can't establish the mqtt connection between IFP & Manager web, it looks like a network connection issue.

    We would suggest whitelist "AWS domain" instead of its "IP address",
    this is because AWS used a long list of dynamic IP address instead of fixed ones. If they still want to use IP address, they may need to whitelist hundreds of IP address, that would not be an efficient way, the list might also be changed in the future.

    let me know if you have any further questions, thank you


  • @peja-cw-chang

    Hi,

    Our service provider cannot use wildcards in their firewall and will not whitelist "AWS" as a domain as they say it is not a secure way of working.

    Are you able to provide a full list of IP addresses used (I know there will be a lot) and I can have each one of them whitelisted individually?


  • @peja-cw-chang

    I have also been asked for clarification on what needs whitelisting. Our provider has asked, Is it the root AmazonAWS.com domain or perhaps ‘something.something.amazonaws.com’?

    Thanks