Issues going from online whiteboard to myViewboard

  • Last year I was pleasantly surprised when the OLF file was added to the online whiteboard. It allowed me to work on the files at home using the internet and open them on my classroom board at school. In order to do this, I linked my account to my Google drive. I would save them and open them on whichever platform I was using.

    As I am getting ready for school this year, I decided to start developing lessons. I saved them as an OLF and tried to open them at school. At school today, I ran into an issue where the file would not open on my classroom board. It would not even read the file that was saved on my Google Drive.

    I did find a workaround, but it is a pain. I can download the file to my board and then access it, but I really should be able to upload the file directly from Google Drive.

    Thank you,

    Brian Greenlaw

  • Hi @brian-greenlaw-msad59-org thank you for the feedback.
    In order to help you soon, can you let us know what product you used to save and to open an OLF:

    1. Whiteboard Online
    2. Classroom
    3. Whiteboard for iOS
    4. Whiteboard for Android
    5. Whiteboard for Windows

    Also, can you provide the OLF file to us, thank you.

    myViewBoard team

  • @kaitlyn-peng-myviewboard-com

    I have saved it from Whiteboard Online and Classroom. Neither worked. Further, I downloaded Whiteboard for iOS it does not even give me the option to use the *.OLF file type. I use a Mac as my primary take-home computer and this is a problem.

    When at school I primarily use Whiteboard for Windows but have also used Whiteboard for Android when I have taught in other teachers' classrooms.

    I want to reiterate that the issue is when saving from the online/classroom to Google Drive. I have not had an issue when going from Windows to Google Drive.


  • Hi, @brian-greenlaw-msad59-org

    Thank you for the detailed information.

    What I am going to do is to collaborate with online Whiteboard/ Classroom and Windows Whiteboard team and to reproduce your issue, so one important thing here is could you please share with us the OLF file that you were unable to access? This will help us facilitating the troubleshooting process. Your file will be safely kept inside ViewSonic.

    OLF format is the cornerstone of myViewBoard ecosystem and we are glad to see that your Whiteboard/OLF application exactly fits to what myViewBoard is designed for. We are happy to see our works can really empower teachers' professionals and with your feedback we are getting myViewBoard a better teaching solution.



  • @mike-yang-viewsonic-com

    Hi Mike,

    I will send/share with you my latest file saved on Google Drive. If I save it to Drive from Online/Classroom, that is when the issue happens. I know that if I download from Google Drive to my Windows Machine and then open it directly from the machine it works. It just won't work from the sequence of Online/Classroom -> Save to Google Drive -> Open from Drive to Windows.

    2.2 Intro to Functions.olf. I am currently working on this file online. Further, I'll upload the image that shows the different file types. I had gone into school and did my workaround on the 2.1 file, but it was like 2.2.

    Screen Shot 2022-08-22 at 12.04.54 PM.png

    I hope this helps.

  • Hi, Brian @brian-greenlaw-msad59-org

    We tried to reproduce the scenario with the file "2.2 Intro to Functions.olf". Here are the reproduce steps:

    • Upload the file to my Google Drive.

    • Use Whiteboard online/Classroom to access the file on Google Drive.

    • Do nothing and "Save As" to a new file on Google Drive.

    • Then use Whiteboard on Windows, login and use File Manager to access my Google Drive.

    • Inside my Google Drive I "cannot" see the OLF file that I just "Save As" from Whiteboard online/Classroom. It is invisible.

    • However if I download the new file to local drive then I can see it and open it in Whiteboard on Windows.

    Just want to check if this is the same scenario that you encountered? Anyway it is definitely an issue that we are going to solve.

    Much appreciated for the great help!


  • @mike-yang-viewsonic-com

    That is the EXACT issue I have been seeing. I appreciate you looking into this.


  • @mike-yang-viewsonic-com

    One workaround that I have found is to save it as an *.olf from the online board to my MacBook. I can then throw it from the Mac to the board.

  • Hi, @brian-greenlaw-msad59-org

    Thanks for this valuable information. By the way, we had figured out that this is the Window Whiteboard issue and we already put it into the list. I hope it can be fixed in early November. I will inform you the status once it is solved.

    Sorry for this inconvenience and thanks again for the sharing.